How to Install Sublime Text on Rocky Linux 8

Install Sublime Text on Rocky Linux 8

In this article, we will have explained the necessary steps to install Sublime Text on Rocky Linux 8. Before continuing with this tutorial, make sure you are logged in as a user with sudo privileges. All the commands in this tutorial should be run as a non-root user.

Sublime Text is a cross-platform source code editor designed with simplicity and speed in mind. The Sublime text editor supports many programming languages, snippets, APIs, various plugins, and other markup languages like various plugins, Java, C#, ASP, and many more. To extend its specific functionality, we can install we appropriate plugins.

Install Sublime Text on Rocky Linux

Step 1. First, before you start installing any package on your Rocky Linux server, we always recommend making sure that all system packages are updated.

sudo dnf update
sudo dnf upgrade

Step 2. Install Sublime Text on Rocky Linux.

Installing Sublime Text on your Rocky Linux system is straightforward, Now import Sublime Text 4 rpm using the following command:

sudo rpm -v --import https://download.sublimetext.com/sublimehq-rpm-pub.gpg

Then, import the stable:

sudo dnf config-manager --add-repo https://download.sublimetext.com/rpm/stable/x86_64/sublime-text.repo

After adding the Sublime Text 4 rpm to the system, then we will update dnf packages and install it:

sudo dnf update
sudo dnf install sublime-text

Verify the Sublime Text version by typing the command line:

subl --version

Step 3. Launch Sublime Text on Rocky Linux.

Once the installation is compiled, launch the Sublime Text on AlmaLinux/Rocky Linux system by executing the following command or you can also open the Sublime Text using the graphical interface:

subl

That’s all you need to do to install Sublime Text on Rocky Linux 8. I hope you find this quick tip helpful. For further reading on the Sublime Text, please refer to their official knowledge base. If you have questions or suggestions, feel free to leave a comment below.